Cannot load package 'samplePropertyEditor.'

Abstract: The error Cannot load package 'samplePropertyEditor.' occurs after install update 2 if you did not uninstall Update 1 or you install update 2 to a different location

Q. After installing Delphi for PHP Update 2, I get the error:

Cannot load package 'samplePropertyEditor.'  It contains unit 'uSamplePropertyEditor,'which is also contained in package 'nativePropertyEditors'.

A. There are two possibles causes for this error.
  1. Not uninstalling your previous install of Delphi for PHP before installing the update
  2. Installing Update 2 to a different location than your previous install of Delphi for PHP. If you wish to install update2 to a different location than your previous install, you need to delete your existing registry entries for Delphi for PHP first. These registry entries exist at HKEY_CURRENT_USER\Software\CodeGear\Delphi for PHP